Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2012
    Location
    SINGAPORE
    Posts
    166

    Default CVT keeps stalling and vibrates alot

    Hi guys, recently I changed my timing belt set, alternator belt, timing belt, engine belt, waterpump, and the different oil seals. After doing the servicing, my RPM drops a lot to 500 when idling, and when I on the aircon, the Tak Tak Tak sound keeps repeating. usually only Tak once when on, but now keep Tak Tak Tak. When in traffic light D gear, the engine vibrates a lot and becomes worst when aircon compressor kicks in, then when I change to N gear it doesn't vibrate. When driving or reversing when I turn steering without giving gas, the rpm drops a lot and engine starts to vibrate violently.

    In the morning when I start my car, it just stalls. I have to give it some gas and hold it, then after 8 seconds its back to normal.

    What do I do guys? Any advice ? thanks a lot..

  2. #2

    Default

    guess its time to change your engine mounting

    do also check on your ignition coil and power cable

  3. #3
    Join Date
    Jan 2008
    Location
    Hougang ave 8
    Posts
    2,524

    Default

    Quote Originally Posted by lancermaster91 View Post
    Hi guys, recently I changed my timing belt set, alternator belt, timing belt, engine belt, waterpump, and the different oil seals. After doing the servicing, my RPM drops a lot to 500 when idling, and when I on the aircon, the Tak Tak Tak sound keeps repeating. usually only Tak once when on, but now keep Tak Tak Tak. When in traffic light D gear, the engine vibrates a lot and becomes worst when aircon compressor kicks in, then when I change to N gear it doesn't vibrate. When driving or reversing when I turn steering without giving gas, the rpm drops a lot and engine starts to vibrate violently.

    In the morning when I start my car, it just stalls. I have to give it some gas and hold it, then after 8 seconds its back to normal.

    What do I do guys? Any advice ? thanks a lot..
    clean your throttle body and check your engine mounts

    Transformation of my ride throughout the years...

    Fuel consumption is opposite in relation to power, increase in the latter decreases the former.

  4. #4
    Join Date
    Oct 2012
    Location
    Tampines
    Posts
    329

    Default

    change ATF already? im used to be in ur shoes, but recently i service using 300v power and change ATF (DiaQueen) and do t.b cleaning no issues at all.... no laggy sluggish pickup... smooth like butter pickup
    -Truth Fears No Questions-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •