Results 1 to 13 of 13

Thread: Advice needed

  1. #1
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default Advice needed

    Hi guys,

    When I step in the clutch there is a sound something like rusty sound. Could it be the pump or plates issue?
    Sometimes biting point is quit near, but mostly is normal biting point.
    Current millage is 97K 1st owner & on stock clutch.
    Thank you...

  2. #2
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    To add on, I don't feel any slipping clutch so far..
    Anyone care to share or have similar experience.

  3. #3
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Please help... Thanks..

  4. #4
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    No body experience this?

  5. #5

    Default

    Does the sound seems like from inside cabin or in engine bay?

    If inside, there is a pin at the clutch pedal stem, just put some grease (last longer) or spray some lubricant like WD40 at the pin area.

  6. #6
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Sound seem like from engine bay... but I can hear it in cabin..

  7. #7

    Default

    Does it happen when shifting from neutral to 1st gear, usually at morning when you first started the car? Does it sound like rubbing sound but rather low pitch kind, not the high screeching sound from auxiliary belts?

  8. #8

    Default

    Hi bro,
    Try to go workshop to confirm bcos might be clutch plate wore-out or loose belt.Safety come first bro take care..��

  9. #9
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Quote Originally Posted by Octopus View Post
    Does it happen when shifting from neutral to 1st gear, usually at morning when you first started the car? Does it sound like rubbing sound but rather low pitch kind, not the high screeching sound from auxiliary belts?
    Every gear also got sound.. even car not moving if I press clutch got sound..

  10. #10
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Quote Originally Posted by Ariffin View Post
    Hi bro,
    Try to go workshop to confirm bcos might be clutch plate wore-out or loose belt.Safety come first bro take care..��
    Thanks bro... will send her for checkup.

  11. #11
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Update.. change whole set clutch plates & bearing.. no more sound...

  12. #12

    Default

    Congrats bro for problem solved.

  13. #13
    Join Date
    Aug 2009
    Location
    IMM
    Posts
    1,136

    Default

    Thank you bro..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •